2020年10月25日日曜日

【故障修理】COTEK SK1000-124 24V 1000W 100V その2 マイコンの動作確認

  前回までのあらすじ

・起動すると下段LEDが緑点滅し、30秒ほどで出力停止。
・制御基板交換で直ることから、制御基板故障
マイコン 12番pin RC1の信号がが正常品と異なる
・アナログポート電圧は同じに見えるがタイミング等細かな部分は不明。

その後のテストで、出力停止後に入力電圧を振って『低電圧停止⇒復帰電圧』で出力復帰を確認。
復帰といっても30秒経つと停止するのは変わりなしです。うぅぅむ。

未使用と思われる18番pin RC7が気になるので、マイクロクリップのテストも兼ねて取り直してみました。
使っていて気付いたのですが、先端部が金属っぽく見えますが、透明の収縮チューブで絶縁されていました。少し高価ですが格段にクリップ力が上がりました。

取得した信号はこちら、残念ながらRC7はLowのまま特に使われている感じはなし。
故障修理としては進展はなかったのですが、リモコンモニタの通信内容を確認することが出来ました。
4800bps N81でコマンドは3種類流れているようです。
起動後の信号の流れは、
⇒"PWRS 2" + CRLF
⇒"QURY 1" + CRLF
⇒"QURY 2" + CRLF
⇒"QURY 0" + CRLF
⇒"QURY 4" + CRLF

⇒"PWRS 2" + CRLF
⇒"QURY 1" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF
⇒"QURY 2" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF
⇒"QURY 0" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF
⇒"QURY 4" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF

⇒"PWRS 2" + CRLF
←0x30,0x0D,0x0A,0x3D,0x3E + CRLF
⇒"QURY 1" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF
⇒"QURY 2" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF
⇒"QURY 0" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF
⇒"QURY 4" + CRLF
←0x30,0x30,0x0D,0x0A,0x3D,0x3E + CRLF

1コマンドに対して2回返信しているようにも見えますね。
⇒"PWRS 2" + CRLF
←"0" CRLF + 0x3D,0x3E + CRLF


2020年10月7日水曜日

【故障修理】COTEK SK1000-124 24V 1000W 100V その1

こちらもブログ読者様からのお預かり品です。

症状は、
・起動すると下段LEDが緑点滅し、30秒ほどで出力停止。

この症状は初めてのなのですが、幸いにも手持ちのDENRYO SK-1000-124 24V 1000Wと同じだったので入れ替えて正常動作。制御基板不良を確認(*´ω`*)
起動後30秒間は100Vが出力されていますので、昇圧段やIGBTの制御回路は正常と思われます。
そうなると、マイコンに入力されるセンサ回路まわりが怪しい。
マイコンの+5Vや、アナログの+12Vラインは正常範囲。
全体としての動作は別として、デジタル入力、アナログ入力も特に差異は見つからず。
Pin13 RC2はIGBT周りの元信号かな?
大まかな回路構成が分かったので、細かな動作を確認します。
上が故障基板、下が正常基板
序盤は同じですが、Ch4の信号が止まっているのが原因の様です。
この信号、最初はパルス状なんですが、
途中から幅が変わっています。2904を通じて電流判定回路にも影響しているようなので気になる。


同じ症状の修理履歴がないかと辿ったところ1件発見。
マイコンのリセットで直ったとか、負荷センサを誤魔化してリセット出来たとか、いまいち信憑性に欠ける内容しかなく、肝心の修理方法は後でアップするよって感じで終わっている。

正直手詰まり状態。もう駄目かな・・・( ;∀;)
もう一度他の部分も確認してみよう。

おまけ
もう少し細かく見てみた。大まかな制御タイミングは同じだが、ここだけは意味不明。
Ch4と連動して動いている場所が見つかればいけるかも。厳しいな。


2020年9月28日月曜日

【故障修理】COTEK SK700-112 12V 700W 100V

 ブログ読者様からのお預かり品です。

症状
・リモコンで電源が入らない。

ボタンを押した瞬間、本体LEDが点灯します。なにか通信で失敗しているのでしょうか?

分解していく中では特に破損した部品はなし。
モジュラーコネクタはとりあえず問題なさそう。
通信といえばST232ドライバ(データシート)
故障を確認したわけではないが、取り外す際にバキッって割れたのでそれなりに劣化していたようだ。
新品に交換したが症状変わらず
切り分けしていく中で、正常品はシリアルケーブルを接続していなくてもコントローラ、本体とも電源が入ることに気づく。通信出来ないとコントローラ側からもアラーム音。本体側故障かな?

本体、電源スイッチ回路。右がコントローラ電源、左がメインスイッチ。
メインスイッチでは抵抗とリモコンを切り替えているだけ。トランジスタで電流を検出して制御基板にスイッチが入ったことを通知しているようだ。
リモコンには正常に12V供給されているし、なんで電源が入らないんだ?
念のため、Q11,Q12のトランジスタをチェックしたが問題なし

うぅぅむ、困った。( ;∀;)

まさかと思うけどメインスイッチが壊れている??
スイッチ部をジャンパで置き換えてみる。
あっさり解決!! 今までの苦労は何だったんだ( ゚Д゚)

手持ちの中古部品と交換して修理完了。
動作テスト
問題なさそうですね。とりあえず完了。
お預かりしたリモコンのスイッチが壊れかけていたので、交換しときました。(*´ω`*)

2020年9月5日土曜日

アウトランダーPHEV GG3W バッテリ 13.8KWh 採掘してきました LEV46-8

 2019年9月 GG3W 走行距離 約17000Km
型番 9450B322  バッテリ容量 13.8KWh エラーコードなし。動作確認済み。
という非の打ち所の無いバッテリですが、このままでは使えないのでバラしていきます^^;


いつものようにネジだけで外せるかと思いきや、ご丁寧にコーキングしてあります( ゚Д゚)
コーキングもそうですが、暑さとの闘い。辛い。

開けてみてればいつものレイアウト、

シロッコファンがひと回り小さくなったような気がする。
ん? なにか見慣れないものが!
これはBMUではないですか!!
バッテリユニットの方はいつもの同じ・・・。
型番がLEV40-8からLEV46-8に変わってます!
電池バックの色が水色になった以外は同じですけどね(*´ω`*)
中も同じ。
プレス記事があったので、メモしときます。



2020年8月30日日曜日

【注意喚起】 LEV40、LEV50、SCiB AM01202のCMUは単独では動作しません!!

 LEV40-8 CMUの信号を覗いてみたで分かったのですが、タイトルのようにCMUはバッテリ単体では動作しないことが分かりました。

単体で使用されている方は十分ご注意願います。

と煽りながら言うのもなんですが、この環境で特にトラブルがなかったのも事実。
恐らくバッテリが高品質で容量も大きいため、通常の使用範囲ではセルバランスが崩れることがほとんど発生しないためだと思われます。ただ、劣化したバッテリは思いのほかバランスが崩れますので過信は禁物です。

バッテリ単体で利用されている方は、定期的に電圧確認し、セルバランスが崩れている場合は使用を止めることをお勧めします。

CMUの動作について
LEV40、LEV50、SCiB AM01202のCMUは外部から12Vを受けて動くようです。
以下はSCiB AM01202のマニュアルから引用です。

また、CMUのセルバランスはBMUからの指示を受けて機能します。

実際にセル電圧 3.88V を 2セルのみ 3.73V 差分150mV としてCMUの様子を確認してみました。
バランス回路も含め、CMU全体は沈黙しています。
マニュアル通り、外部から+12Vを供給すると、CMU内の電圧レギュレータが動き出します。
バランス回路も定期的に動いていますが、殆ど電流は流れていません。
BMU、CMUの動作について(推測)
  1. BMU、CMUへの+12V供給でシステム起動。
  2. BMUからCMUへバッテリ電圧確認コマンド派出。
  3. CMUは定期的に、バランス状態、温度、セル電圧について報告。
  4. BMUはセル電圧を確認し、規定値以上に差分がある場合はセルバランスを指示
    この際に目標電圧を指定することで、CMUは指定電圧以上のセルを放電
  5. BMUは全てのCMUのバランスが停止したら、バランス完了とする。
    ※コマンドによる指示は一過性で、連続してバランスする場合はコマンド送信の継続が必要。
までCMUがバランスしてくれるから安心って思っていただけに、自分もビックリです。
海外では有志が独自BMSを製作していますが、日本では手に入れづらいのでなんとか対策しないとですね。

2020年8月27日木曜日

【故障修理】 COTEK SK-1500-112 12V 1500Wインバータ

 お友達からの修理依頼です。

故障内容
・接続ミスで商用電力からインバータに流れ破損。

どの様に接続ミスしたのか非常に気になりますが、壊れてしまったものは仕方がない。
とりあえず分解してみます。

時間が経ったせいか、焦げたにおいはそんなに強くない。
外観はいたって普通。フレームがかなり曲がっていたり、径の異なるネジが使われたりと、開封歴はあるようだが、シリコン材が開封されていないことから、それ以上の分解はされていないようだ。

50Aヒューズは全て正常。このことからインバータが動作していないときに破損したようだ。
問題のIGBT部分。一番右の足が溶断している。凄まじい。(@_@;)
フィンを外してみた。パターンとか抵抗は大丈夫そう。
念のためIGBTとフォトカプラを外してみた。IGBTは全損。
フォトカプラは問題なさそうに見えるが、安い部品なので保全交換とする。
放熱フィンの下まで熱が廻った模様。基板表面も燃えて繊維が見えている。
絶縁は確保できているようだ。
IGBT周辺の抵抗など正常。
念のため、昇圧段とか確認してみたが、特に異常なし。
新品のAT350を実装して動作テストしてみた。
昇圧段問題なし。
IGBT駆動波形、問題なし。
溶けた絶縁シートはカプトンテープで補修。


写真とるの忘れましたが、IGBTは修理費用を抑えるため中古部品利用。
仮組し動作テスト。動き始めました。
無負荷時で12.3W。マニュアル値が1.45Aなので良好。
本組して、電圧テスト良好。100W負荷にてファン回転正常。
遠隔ユニット良好。
少しエージングしてから返却予定。
本来であれば1000W程度の負荷テストをしたいのですが、環境が整っていないので許してもらおう。^^;